Membuat Voucher Hotspot Mikrotik

Apabila kita pergi ke cafe atau ‘Warung Internet‘ dan ingin akses internet dengan layanan hotspot, kita akan diminta untuk membeli voucher. Pada voucher tersebut biasanya tertulis seperti ‘Username‘, ‘Password‘, ‘Harga‘, ‘Quota/Durasi Waktu‘. Nah, lalu bagaimana cara membuat voucher tersebut?

Mikrotik telah menyediakan sebuah sistem aplikasi yang mana digunakan untuk melakukan manajemen user dari layanan hotspot. Sistem aplikasi seperti yang sering kita dengar yaitu User Manager. Sistem aplikasi ini merupakan web based dan terintegrasi dengan fitur Radius yang ada di Router Mikrotik. Salah satu kelebihan dari sistem aplikasi ini adalah kita bisa men-generate voucher hotspot secara otomatis sesuai dengan data user yang ada pada list di UserManager.

Pada pembahasan kali ini kita akan lebih memfokuskan bagaimana cara men-generate voucher hotspot dan juga memodifikasi tampilan dari voucher tersebut. Dalam membuat voucher hotspot sebetulnya cukup mudah. Pertama, kita masuk ke menu ‘Users‘ pada User Manager, kemudian pilih akun mana yang akan di cetak dalam voucher. Selanjutnya klik Generate > Vouchers.

Kita bisa menentukan apakah hasil dari voucher tadi akan disimpan dalam bentuk file atau langsung di tampilkan pada halaman web browser. Jika kita ingin menyimpan dalam bentuk file kita centang opsi ‘Download as File‘. Pada contoh kali ini kita akan langsung menampilkan voucher pada halaman web browser. Selanjutnya klik pada tombol ‘Generate‘. Secara otomatis akan ditampilkan sebuah voucher yang berisi informasi standart dari sistem.

Modifikasi Tampilan Voucher Hotspot

Kita juga bisa melakukan editing terhadap tampilan standart dari voucher hotspot tersebut sesuai dengan yang kita inginkan. Untuk mengubah tampilan tersebut, kita masuk pada menu ‘Settings‘ pilih pada TabTemplate. Jangan lupa untuk menetukan parameter ‘Name = Vouchers‘. Nah, disini kita akan melakukan editing script yang digunakan untuk men-generate voucher. Karena menggunakan script HTML, setidaknya kita telah familiar dengan bahasa HTML.

Ada sebuah parameter khusus dari User Manager yang bisa di aplikasikan dengan bahasa HTML yang nantinya secara otomatis akan menampilkan informasi data dari akun user seperti pada konfigurasi di user profile. Parameter tersebut dikenal sebagai Character Constants.
Untuk parameter yang kita gunakan pada contoh pembahasan kali ini yaitu,%u_username%: Username
%u_password% : Password
%u_actualProfileName%
  : Nama User Profile
%u_moneyPaid% : Harga dari voucher

Masih banyak Character Constants yang dapat digunakan untuk membuat informasi data secara otomatis. Kita bisa melihatnya pada link berikut.

Nah, contoh tampilan voucher yang telah kita buat seperti di bawah ini.

Sumber:  mikrotik.co.id   http://wp.me/p7YtqJ-2

Advertisements

 Step By Step konfigurasi AutoUpdate IP Public Dynamic dengan FreeDDNS pada Mikrotik Router

Berikut ini saya sharing Step By Step konfigurasi AutoUpdate IP Public Dynamic dengan FreeDDNS pada Mikrotik Router. Artikel semacam ini sebetulnya sudah banyak dibuat dan di sharing di Mikrotik Wikipedia, namun saya buat artikel ini untuk memudahkan pemahaman dan memudahkan dalam implementasi-nya.

Latar belakang pembuatan artikel ini adalah karena layanan internet dari Provider Telkom Speedy danProvider First Media di Indonesia, dll hanya memberikan layanan IP Public Dynamic. Sedangkan dengan adanya fasilitas IP Public ini dapat memberikan kemudahan bagi pelanggan untuk memanfaatkan IP Public tersebut untuk berbagai hal fungsional yang lebih bermanfaat lagi.

Kegunaan atau pemanfaatan IP Public tersebut diantaranya  kita dapat :

  • Membuat WebServer sendiri,
  • Membuat FTP Server sendiri,
  • Membuat VPN Server sendiri,
  • Membuat IP PBX Server sendiri dan lain-lain .

Sehingga tidak perlu keluar biaya yang lebih banyak untuk layanan hosting. Serta dengan server sendiri ini kita bisa membuat layanan Unlimited bandwith / quotalayanan Webserver unlimited space dan unlimited resourcememudahkan installasi maupun konfigurasi security-nya ( karena bukan shared hosting), dll. Karena untuk hardware-nya kita bisa provide sendiri sesuai keinginan kita dan sesuai budget yang kita miliki.

So… apa saja langkah-langkah agar kita bisa membangun layanan server sendiri tersebut???

1. Kita memiliki layanan Internet dengan IP Public Dynamic ( Speedy, Fastnet, dll ) serta mengunakan Router Mikrotik ( RouterBoard Mikrotik, PC Router Mikrotik, VM Router Mikrotik, dll.

2. Selanjutnya kita melakukan Registrasi di websites :www.changeip.com

3. Setelah melakukan registrasi, kita lakukan Logindan melakukan registrasi namasubdomain untuk menentukan layanan DDNS yang kita inginkan. Pada contoh ini saya memilih subdomain FreeDDNS.com,MyDDNS.comDynDNSPro.com dengan nama subdomainThinkxfree.

4. Selanjutnya kita klik menu DNS Manager. Dan akan terlihat sejumlah nama Subdomainyang telah kita register.

6. Selanjutnya jika kita klik menu View Recent DDNS Updates maka akan terlihat IP Publicyang sudah di register pada Subdomain tersebut. Nah, IP Public ini kita bisa ganti secara manual ataupun secara otomatis. Jika mau meng-update secara otomatis ada beberapa cara. YaituUpdate via Tools / software DNS Client Updater ataupun mengunakan update via Router.

7. Untuk Update via Tools / software DNS Client Updater, kita bisa download software-nya seperti dibawah ini :

http://www.changeip.com/accounts/download

8. Untuk Updater via router Mikrotik, caranya adalah :

  • Membuat Script HomingBeacon Updater dari menu System Script.
  • Membuat Secheduler yang kita set permenit ( atau sesuka anda ) untuk menjalankanScript HomingBeacon Updater.

9. Dari Mikrotik Winbox, Pilih menu System Scriptuntuk membuat Script HomingBeacon Updaterseperti gambar dibawah ini. Lalu kita klik Apply / OK.

10. Selanjutnya dari menu System Secheduler kita buat sebuah sechedule baru yang kita set permenit ( atau sesuka anda ) untuk menjalankan Script HomingBeacon Updater yang telah kita buat tadi.

11. Tentukan nama Sechedule dan interval jalannya Script. Lalu pada pilihan On Event, taruh nama Script yang sudah kita siapkan. Lalu kita klik OK / Apply.

12. Dan selanjutnya kita kita hasilnya seperti gambar dibawah ini.

13. Selanjutnya kita pantau di ChangeIP.com hasil perubahan dari mikrotik tersebut.

14. Selanjutnya akan terlihat seperti gambar dibawah ini.

15. Selanjutnya langsung kita test dengan mengaksesWebFig via thinkxfree.freeddns.comseperti gambar di bawah ini.

16. Lebih lanjut kita dapat mengakses VPN Serverdari Mikrotik kita seperti gambar dibawah ini.

17. Untuk memudahkan anda, silahkan COPY PASTE Script dibawah ini, mudah sekali bukan??? Selamat mencoba… :

# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# EDIT KONFIGURASI SESUAI ACCOUNT ANDA
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnsuser "NathanGR"
:global ddnspass "Password"
:global ddnshost "thinkxfree.freeddns.com"
:global ddnsinterface "SPEEDY"
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# END OF USER DEFINED CONFIGURATION
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
:global ddnslastip
:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: Gak ada interface dengan nama $ddnsinterface, check konfigurasinya lagi Mas Bro." }
:if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = "nothing" ) do={
:log info ("DDNS: Gak ada IP Address di " . $ddnsinterface . ", check dong Mas Bro.")
} else={
:if ($ddnsip != $ddnslastip) do={
:log info "IP Public : $ddnsip."
:log info "DDNS: UPDATE Sukses Mas Bro!"
:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
:global ddnslastip $ddnsip
} else={
:log info "IP Public : $ddnsip."
:log info "DDNS: Gak ada perubahan IP Public Mas Bro."
}
 }

# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

sumber:

https://thinkxfree.wordpress.com/2014/01/20/step-by-step-konfigurasi-autoupdate-ip-public-dynamic-dengan-freeddns-pada-mikrotik-router/

 Step By Step konfigurasi AutoUpdate IP Public Dynamic dengan FreeDDNS pada Mikrotik Router

 

Sumber : http://wp.me/p26G58-14

Cara Membatasi (Limit) Bandwidth Mikrotik dengan Simple Queue Mikrotik

Cara Membatasi (Limit) Bandwidth Mikrotik dengan Simple Queue Mikrotik – Mengatur dan membatasi pemakaian Bandwidth internet memang suatu hal yang penting ketika koneksi internet kita terbatas, misalnya kuota bandwidth yang terbatas dari ISP. Kita perlu membatasi kuota bandwidth tiap user yang terkoneksi ke Router Mikrotik. Pada Router Mikrotik sendiri sudah tersedia fitur yang bisa membatasi (limit) bandwidth yaitu Queue. Ada dua macam Queue pada Mikrotik :
  1. Queue Simple : merupakan cara termudah untuk melakukan management bandwidth yang diterapkan pada jaringan skala kecil sampai menengah untuk mengatur pemakaian bandwidth upload dan download tiap user.
  2. Queue Tree : mirip seperti queue simple tapi lebih rumit, yaitu dapat melakukan pembatasan bandwidth berdasarkan group bahkan secara hierarki. Kita harus mengaktifkan fitur Mangle pada Firewall jika ingin menggunakan Queue Tree.
Pada artikel kali ini kita akan membahas fitur Queue Simple dulu. Oke, mari kita belajar mikrotik bersama 🙂
Untuk pembahasan Queue Simple kali ini kita akan mencoba praktek membuat limit Bandwidth semua user dengan mikrotik. Silakan buka Winbox nya dan pilih menu Queues, maka akan muncul tampilan berikut :
Sebelum kita mulai membatasi Bandwidth internet dengan mikrotik, pastikan dulu berapa Bandwidth Internet yang anda dapat dari ISP yang anda pakai. Sehingga nantinya nilai Bandwidth yang dilimit tidak melebihi alokasi Bandwidth dari ISP. Misalnya bandwidth dari ISP sebesar 1 Mbps, maka limit bandwidth nya diset lebih kecil atau sama dengan 1 Mbps.
Untuk menambahkan Simple Queue baru klik tombol +, maka akan muncul tempilan seperti berikut :
Ada beberapa tab di jendela Simple Queue tersebut, namun kita hanya akan menggunakan tab General dan Advanced saja.
 
Tab General
Pada tab General ada beberapa pilihan yang dapat diseting. Yang perlu kita perhatikan dengan seksama yaitu pilihan Target Address dan Max Limit.
Target Address
Anda dapat mengisis Target Address dengan IP address tertentu yang ingin anda batasi Bandwidth nya, misal 192.168.100.0/24. Dari gambar di atas bisa dilihat untuk Target Address kosong, ini berarti konfigurasi limit Bandwidth ini berlaku untuk semua alamat IP.
Max Limit
Max Limit adalah alokasi bandwidth maksimal yang bisa didapatkan user, dan biasanya akan didapatkan user jika ada alokasi bandwidth yang tidak digunakan lagi oleh user lain. Jangan lupa centang Target Upload dan Target Download untuk mengaktifkan fitur ini, pilih besar Bandwidth yang ingin dilimit pada Max Limit. Misalnya upload : 256kbps download : 1Mbps.
Besar limit Bandwidth untuk upload lebih rendah daripada download nya karena memang user biasanya lebih banyak melakukan download (browsing, download musik, file, dll) daripada upload. Anda dapat memilih sesuai keinginan.
Anda juga dapat menentukan waktu kapan dan berapa lama Simple Queue ini akan mulai berjalan dengan memilih opsi Time.
Tab Advanced
Pada tab Advanced hal yang perlu diperhatikan pada opsi Interface dan Limit At.
Interface
Pilih interface mana yang ingin dibatasi bandwidth nya, misalnya interface Wlan1 untuk membatasi koneksi internet via wireless. Jika ingin membatasi bandwidth di semua Interface pilih all.
 
Limit At
Limit At adalah alokasi bandwidth trendah yang bisa didapatkan oleh user jika traffic jaringan sangat sibuk. Seburuk apapun keadaan jaringan, user tidak akan mendapat alokasi bandwidth dibawah nilai Limit At ini. Jadi Limit At ini adalah nilai bandwidth terendah yang akan didapatkan oleh user. Nilai nya terserah anda mau diisi berapa. Misalnya diisi upload 128kbps download : 512kbps.
Nah, dari konfigurasi tersebut, maka hasilnya jika semua user sedang memakai koneksi internet dan kondisi jaringan sibuk maka tiap user akan mendapatkan bandwidth sebesar 128kbps/512kbps. Jika satu atau beberapa user tidak sedang menggunakan koneksi maka alokasi bandwidth akan diberikan ke user yang sedang terkoneksi. Dan jika hanya satu user yang menggunakan koneksi maka user itu akan mendapatkan alokasi bandwidth maksimal 256kbps/1Mbps.
Klik ok untuk menambahkan Simple Queue tersebut, sehingga akan muncul di queue list.
Pada gambar di atas, ada dua Simple Queue, yaitu Simple Queue yang terbentuk secara otomatis oleh Hotspot di artikel sebelumnya Cara Membuat Hotspot di Mikrotik : Seting dasar Hotspot Mikrotik
dan Simple Queue yang baru dibuat. Jika ada dua konfigurasi berbeda maka akan dieksekusi dari atas ke bawah (top to bottom), jadi Simple Queue hotspot dieksekusi dulu baru kemudian Simple Queue Mikrotik Indo. Walaupun Simple Queue hotspot Tx Rx Max limit nya unlimited, tapi semua user hotspot akan mendapatkan bandwidth Max Tx Rx 256k/1M dari Simple Queue MikrotikIndo, sehingga Simple Queue hotspot itu tidak berlaku.

Anda dapat mengatur konfigurasi Simple Queue sesuai selera anda sendiri. Silakan anda kembangkan sesuai keinginan anda sendiri. oke, semoga Tutorial Mikrotik Indonesia tentang Cara Membatasi (Limit) Bandwidth Mikrotik dengan Simple Queue Mikrotik ini bermanfaat. Selamat belajar Mikrotik 🙂
Sumber : http://mikrotikindo.blogspot.com/

Enable dan Disable, dan Uninstall package Mikrotik

Di bab ini kita akan membahas tentang Enable dan Disable, dan Uninstall packet Mikrotik. Dalam mikrotik, terdapat banyak fitur-fitur yang berbentuk packet, yang tentu saja packet-packet tersebut bisa di manage atau dikelola. Untuk bisa melihat packet-packet yang tersedia, kita tinggal mengetik command ini : Continue reading “Enable dan Disable, dan Uninstall package Mikrotik”

Allow WhapApps Chat & Voice Call only di Mikrotik

Ada kebutuhan untuk beberapa user tertentu yang terhubung ke network cuman bisa akses WA aja , baik itu chat & voice call WA maupun WA web.. Lebih dari itu ( kayak akses internet , akses ke jaringan lokal ) diblok..

Berarti kan yang dibutuhkan ada tiga , yaitu yang pertama IP address server WhatsApp , yang kedua IP address user yang terhubung , kemudian yang ketiga rule firewall MikroTik Continue reading “Allow WhapApps Chat & Voice Call only di Mikrotik”

Cara Membuat Notifikasi SMS The Dude (Aplikasi Monitoring Jaringan)

Cara memonitor perangkat jaringan (Router, Switch, Server, dll), jika ada perubahan status perangkat misal dari up ke down dan sebaliknya maka akan ada notifikasi SMS yang masuk ke HP Anda. Hal ini bisa kita lakukan dengan bantuan Aplikasi monitoring jaringan Gratis buatan Mikrotik, yaitu The Dude.
Apa itu The Dude? Bagaimana Cara Install The Dude? Silakan baca artikel sebelumnya tentang The Dude Mikrotik :
Dari sini saya anggap Anda sudah bisa menginstall The Dude dan sudah membuat Network Map sesuai topologi jaringan Anda. Mulai dari sini kita akan langsung masuk ke Tutorial Cara Membuat Notifikasi SMS pada Aplikasi The Dude.

Apa saja yang perlu kita siapkan?

1. Aplikasi The Dude yang sudah terinstall dan siap digunakan (Bisa pakai versi lama atau baru)
2. Modem USB, untuk mengirim SMS
3. Aplikasi Plink SSH, untuk mengirim command dari The Dude ke Mikrotik via SSH

Langkah pertama

Menginstall Modem USB di Mikrotik untuk mengirim SMS. Caranya sudah pernah saya bahas disini :

Langkah kedua

Membuat user dummy di Mikrotik yang akan digunakan untuk mengirim command SMS ke Mikrotik.
Silakan buat user baru dengan role/Group write.

Langkah ketiga

Copy plink.exe ke direktori c:\plink

Langkah keempat

Membuat notifikasi baru di The Dude. Buka The Dude –> Masuk ke menu Notifications –> Buat Notifikasi bar –> beri nama notifikasi nya misal “SMS Notification” –> centang Enabled –> Pilih type : execute locally
Pada kolom Command isikan script dengan format sebagai berikut :
C:\plink\plink.exe -ssh -l mikrotik_sms_username -pw mikrotik_sms_password mikrotik_sms_ipaddress “/tool sms send phone-number=nomorhpanda usbportnumber message=\”[Probe.Name] on [Device.Name] is now [Service.Status]\””

Langkah kelima

Terapkan (apply) notifikasi yang sudah dibuat ke Network Map yang ingin kita pantau perangkat nya. Masuk ke Network Map yang diinginkan –> klik menu Settings –> Masuk ke tab Polling –> centang Use Notifications –> centang SMS Notification.

Langkah keenam

Tes konfgurasi nya dengan mencoba meng-offline-kan (meng-down-kan) perangkat yang dimonitor. Jika Konfigurasi sudah benar, maka akan ada notifikasi SMS yang masuk ke HP Anda.

Langkah ketujuh

Dari contoh hasil notifikasi di atas ada 2 perangkat yang down, tapi notifikasi SMS yang masuk ada 10 SMS. Jika notifikasi yang masuk dirasa terlalu banyak, kita bisa kurangi hanya 1 SMS saya per perangkat, yaitu dengan hanya mengaktifkan service ping pada tiap perangkat yang dimonitor.
Caranya dengan dobel klik ke masing-masing perangkat –> Masuk ke tab Services –> Hapus semua service nya kecuali ping, atau sesuai keinginan Anda.
Selesai sudah Tutorial Cara Membuat Notifikasi SMS pada Aplikasi The Dude. Jika perangkat yang Anda Monitor sangat banyak, Anda bisa coba kolaborasikan dengan Notifikasi Email The Dude, caranya sudah pernah saya bahas disini :
Jika Tutorial Mikrotik ini dirasa kurang jelas, silakan Anda tonton video presentasi saya pada saat Mikrotik User Meeting (MUM) Indonesia 2016 di Jakarta berikut ini :
Cara Membuat Notifikasi SMS The Dude (Aplikasi Monitoring Jaringan)
Anda juga bisa download file Presentasi MUM ID 2016 saya disini :
Oke, selamat mencoba dan semoga bermanfaat 🙂
Sumber : http://mikrotikindo.blogspot.com