Cara Limit Akses Video Youtube dengan Layer 7 Protocols

Sekali lagi biar gak lupa ya saya catet disini, cara limit akses video youtube dengan regexp (regular expression) pada layer 7 protocols di mikrotik, alhamdulillah work!!

Pertama, Masukkan regexp berikut pada layer 7 protocols. Ketikkan perintah berikut pada Terminalmikrotik, pastikan tidak ada satu karakterpun yang keliru.

/ip firewall layer7-protocol

add name=Youtube regexp="r[0-9]+---[a-z]+-+[a-z0-9-]+\.googlevideo\.com"

Jika pada winbox hasilnya seperti ini :

Kedua, Membuat mangle untuk shaping trafik/koneksi streaming youtube menggunakan regexp yang telah dibuat sebelumnya, kemudian dari koneksi yang didapat akan ditandai menjadi packetyang akan di proses lebih lanjut oleh queue.

/ip firewall mangle

add action=mark-connection chain=prerouting layer7-protocol=Youtube new-connection-mark=yt_video_conn in-interface=[interface yang akan di limit] passthrough=yes comment=Conn-YT

add action=mark-packet chain=prerouting connection-mark=yt_video_conn new-packet-mark=yt_video_pkt passthrough=no

Jika pada winbox hasilnya seperti ini :

Ketiga, Masukkan hasil shaping koneksi dan paket diatas kedalam simple queue,

/queue simple

add max-limit=1M/3M name="Limit YT "packet-marks=yt_video_pkt target=[interface yang akan di limit]

Jika pada winbox hasilnya seperti ini :

Dari gambar step 2 sudah terlihat ada packet yang lewat dan gambar step 3 terlihat akses ke youtube sudah terlimit sebesar 3M untuk download nya dimana queue tersebut sudah berwana merah.

*Tambahan

Jika memang ingin menutup akses ke youtube, cukup dengan filter firewall berikut :

/ip firewall filter
add chain=forward layer7-protocol=Youtube comment="Blok Youtube" action=drop

Berikut hasilnya, youtube masih bisa diakses namun untuk memutar video dia tidak bisa: 

Terlihat juga jumlah packet yang tertangkap dari filter tersebut.

Sumber : Cara Limit Akses Video Youtube dengan Layer 7 Protocols – http://wp.me/p7ugE3-16V

Advertisements

Leave a Reply