Konfigurasi VLAN Trunk pada Mikrotik

A. Pengertian

       Virtual LAN atau disingkat VLAN merupakan sekelompok perangkat pada satu LAN atau lebih yang dikonfigurasikan (menggunakan perangkat lunak pengelolaan) sehingga dapat berkomunikasi seperti halnya bila perangkat tersebut terhubung ke jalur yang sama, padahal sebenarnya perangkat tersebut berada pada sejumlah segmen LAN yang berbeda. Vlan dibuat dengan menggunakan jaringan pihak ke tiga. VLAN merupakan sebuah bagian kecil jaringan IP yang terpisah secara logik. VLAN memungkinkan beberapa jaringan IP dan jaringan-jaringan kecil (subnet) berada dalam jaringan switched switched yang sama. Agar computer bisa berkomunikasi pada VLAN yang sama, setiap computer harus memiliki sebuah alamat IP dan Subnet Mask yang sesuai dengan VLAN tersebut. Switch harus dikonfigurasi dengan VLAN dan setiap port dalam VLAN harus didaftarkan ke VLAN. Sebuah port switch yang telah dikonfigurasi dengan sebuah VLAN tunggal disebut sebagai access port.

Sebuah VLAN memungkinkan seorang Administrator untuk menciptakan sekelompok peralatan yang secara logic dihubungkan satu sama lain. Dengan VLAN, kita dapat membagi jaringan switch secara logik berdasarkan fungsi, departemen atau project team .

Keuntungan menggunakan VLAN
Penerapan sebuah teknologi VLAN memungkinkan sebuah jaringan menjadi lebih fleksibel untuk mendukung tujuan bisnis. Berikut ini beberapa keuntungan menggunakan VLAN:
  • Security– Departemen yang memiliki data sensitive terpisah dari jaringan yang ada, akan mengurangi peluang pelanggaran akses ke informasi rahasia dan penting.
  • Cost reduction – Penghematan biaya dihasilkan dari tidak diperlukannya biaya yang mahal untuk upgrades jaringan dan efisiensi penggunaan bandwidth dan uplink yang tersedia.
  • Higher performance – Dengan membagi jaringan layer 2 menjadi beberapa worksgroup secara logik (broadcast domain) mengurangi trafik yang tidak diperlukan pada jaringan dan meningkatkan performa.kjk
  • Broadcast storm mitigation – Dengan membagi sebuah jaringan menjadi VLAN mengurangi jumlah peralatan yang berpartisipasi dalam broadcast storm.
  • Improved IT staff efficiency – Dengan VLAN pengelolaan jaringan lebih mudah, karena user-user dengan kebutuhan jaringan yang sama berbagi VLAN yang sama.
  • Simpler project or application management – Memiliki fungsi-fungsi terpisah mempermudah pengelolaan sebuah project atau bekerja dengan aplikasi khusus.

Trunk adalah link point-to point diantara satu atau lebih interface ethernet device jaringan seperti router atau switch. Trunk Ethernet membawa lalu lintas dari banyak VLAN melalui link tunggal. Sebuah VLAN trunk mengijinkan kita untuk memperluas VLAN melalui seluruh jaringan. Jadi link Trunk digunakan untuk menghubungkan antar device intermediate. Dengan menggunakan port trunk, dapat digunakan sebuah link fisik untuk menghubungkanbanyak VLAN.

B. Latar Belakang

Untuk memberikan penjelasan bagaimana cara menghubungkan 2 Host sejaringan menggunakan VLAN menggunakan Mikrotik serta memberikan gambaran bagaimana VLAN itu bekerja. Selain itu untuk penghematan perangkat dalam menghubungkan jaringan satu dengan jaringan lainnya.

C. Alat dan Bahan

– PC/ Laptop
– 2 Buah Mikrotik
– 3 Kabel StraightTrhough/CrossOver

D. Jangka Waktu

 Kurang dari 60 menit

E. Maksud dan Tujuan

Tujuan nya adalah untuk membuat jalur Virtual LAN menggunakan Mikrotik,karena dengan VLAN ini kita tidak akan bermain IP pada interface fisik tsb, melainkan kita biarkan dan hanya mengatur IP dari Host yang terhubung menadi satu subnet saja. Oleh karena itu Mikrotik disini juga bisa berfungsi sebagai Switch managable. Dengan  menggunakan VLAN ini maka kita akan membuat jalur baru secara virtual dalam Port Ethernet fisik yang sebenarnya.

F. Tahapan

1. Pertama – tama buat topologi seperti berikut.
Gambar Bridge di topologi diatas merupakan Router Mikrotik yang difungsikan menjadi Bridge Hub, karena jalur VLAN menumpang pada Interface fisik, maka dari itu kita gunakan bridge.
2. Kemudian buat trunk pada ether5 sesuai dengan topologi diatas, dengan cara membuat vlan 10 dan vlan 20 pada ether5 pada kedua router.
Melalui mode CLI/Terminal
/interface vlan add name=vlan-10 vlan-id=10 interface=ether5 disabled=no
/interface vlan add name=vlan-20 vlan-id=20 interface=ether5 disabled=no
Melalui Winbox/GUI
– Masuk ke menu Interface
– Lalu klik Add (+), untuk menambah Interface baru
– Kemudian pilih VLAN, untuk menambahkan interface VLAN baru
– Selanjutnya buat VLAN nya ( isi nama vlan-> vlan id-> master interface-> Apply & Ok )
– Lalu ini hasilnya.
3. Selanjutnya kita buat interface bridge untuk masing – masing vlan
Melalui mode CLI/Terminal 
/interface bridge add name=br-vlan10 disabled=no
/interface bridge add name=br-vlan20 disabled=noMelalui Winbox/GUI

– Masuk ke menu Bridge
– Lalu klik Add (+) untuk menambah interface Bridge baru
– Selanjutnya beri nama pada interface Bridge nya tsb
– Kemudian ini adalah hasilnya
 
4. Lalu daftarkan port dari ether dan vlan mana saja ke bridge yang sesuai,yang telah kita buat sebelumnya.
Melalui mode CLI/Terminal 
/ interface bridge port add interface=”vlan-10″ bridge=”br-vlan10″ disabled=no
/ interface bridge port add interface=”ether1″ bridge=”br-vlan10″ disabled=no/ interface bridge port add interface=”vlan-20″ bridge=”br-vlan20″ disabled=no
/ interface bridge port add interface=”ether2″ bridge=”br-vlan20″ disabled=no

 Melalui Winbox/GUI
– Masuk ke Tab Ports pada Menu Bridge, lalu klik Add (+)
– Pilih interface ether yang akan di bridge, lalu pilih juga interface bridge nya.
– Pilih interface VLAN yang akan di bridge, lalu pilih juga interface bridge nya.
– Maka hasilnya akan menjadi seperti ini.
 
5. Lakukan langkah nomor 2 -4 diatas untuk Router Mikrotik yang kedua juga 
 
6. Selanjutnya kita lakukan pengujian dengan menggunakan Client yang terhubung pada kedua sisi ether Router yang telah terkonfigurasi vlan.
Client VLAN 1 Router1 -> Client VLAN 1 Router2, hasilnya berhasil
 
Client VLAN 2 Router1 -> Client VLAN 2 Router2, hasilnya berhasil
Client VLAN 1 Router1 -> Client VLAN 1 Router2 , hasilnya tidak berhasil
 
Semoga Bermanfaat 🙂

G. Hasil dan Kesimpulan

Dalam konfigurasi yang dilakuka diatas, terdapat ebberapa hal yang harus diperhatikan misalnya saja interface yang akan di buat VLAN, VLAN ID, maupun interface yang akan di bridge. Alasan kita membuat interface bridge juga dalam pembuatan VLAN ini adalah karena interface VLAN tidak bisa membuat jalur sendiri, maka dari itu VLAN tsb menumpang pada interface fisik (ether) yang nantinya di bridge agar bisa menumpang.

H. Referensi

Ebook Vlans on Mikrotik Environment.pdf

Leave a Reply