Contoh Cara Setting OSPF Di MikroTik

Dibawah ini adalah contoh cara setting OSPF single-area di MikroTik. OSPF adalah routing protocol jenis link state yang dengan cepat mendeteksi perubahan dan mejadikan routing kembali konvergen dalam waktu singkat dengan sedikit pertukaran data. OSPF menggunakan konsep area dengan routing domain OSPF. Area memisahkan network menjadi lebih kecil untuk mengurangi jumlah trafik protokol yang melalui network. Metric OSPF berdasarkan bandwith dari port. OSPF memilih jalur yang mempunyai bandwith paling besar.

 

Kita anggap kita punya topologi sebagai berikut.

setting ospf mikrotik

Contoh jaringan diatas terdiri dari 3 router yang terhubung bersama dengan network 10.10.1.0/24 dan masing-masing router mempunyai 1 jaringan LAN. Dan mempunyai 1 gateway ke internet pada MikroTik R1. Contoh setting OSPF di MikroTik ini di konfigurasi dengan IP address :

[[email protected]]/ip address add address=10.10.1.1/30 interface=ether1
[[email protected]]/ip address add address=10.10.1.5/30 interface=ether2
[[email protected]]/ip address add address=192.168.1.1/24 interface=ether3
[[email protected]]/ip address add address=172.22.0.2/30 interface=ether4
[[email protected]]/ip address add address=10.10.1.6/30 interface=ether1
[[email protected]]/ip address add address=10.10.1.9/30 interface=ether2
[[email protected]]/ip address add address=192.168.2.1/30 interface=ether3
[[email protected]]/ip address add address=10.10.1.2 /30 interface=ether1
[[email protected]]/ip address add address=10.10.1.10/30 interface=ether2
[[email protected]]/ip address add address=192.168.3.0/24 interface=ether3

Ada tiga elemen dasar konfigurasi OSPF di MikroTik :

  • Mengaktifkan OSPF instance
  • Konfigurasi OSPF area
  • Konfigurasi OSPF network

Mengaktifkan OSPF instance di MikroTik

OSPF instance dapat dikonfigurasi di menu /Routing OSPF. Untuk advanced setup OSPF, memungkinkan untuk menjalankan beberapa OSPF instance. Dalam contoh ini saya menggunakan Default instance.

Dalam default instance router-id 0.0.0.0, dalam arti router akan menggunakan salah satu IP address router sebagai router-id. Setiap router OSPF harus menggunakan identitas (ID) sebagai pengenal satu sama lain. ID juga digunakan sebagai penunjuk dari mana sebuah LSA berasal. Jika tidak dikonfigurasikan, maka router OSPF akan mengambil IP Address dari salah satu interfacenya yang aktif untuk dijadikan Router ID. Dan bila terdapat beberapa IP Address, maka IP Address tertinggi yang akan dipilih.

Dalam beberapa kasus di rekomendasikan untuk membuat Loopback IP Address sebagai router-id. Loopback IP Address adalah virtual, IP tersebut bisa digunakan untuk identitas router dalam jaringan. Interface Loopback merupakan interface yang tidak pernah berada dalam posisi “down”, sehingga IP Address pada interface ini sangat cocok untuk dijadikan Router ID.

Konfigurasi Loopback Interface :

[[email protected]] /interface bridge add name=loopback
[[email protected]] /ip address add address=10.255.255.1/32 interface=loopback
[[email protected]] /routing ospf instance set 0 router-id=10.255.255.1 distribute-default=always-as-type-1

Karena R1 mempunyai jalur gateway ke internet jadi saya menambahkan option distribute-default=always-as-type-1. OSPF juga dapat digunakan untuk menyebarkan (redistribute) konfigurasi statik routing yang ada pada sebuah router. Sehingga entry static routing tersebut akan diketahui oleh router OSPF lainnya. Redistribute ini umumnya diterapkan pada router OSPF yang terhubung ke jaringan luar (outside network), misalnya pada R1 berfungsi sebagai gateway ke Internet.

[ad[email protected]] /interface bridge add name=loopback
[[email protected]] /ip address add address=10.255.255.2/32 interface=loopback
[[email protected]] /routing ospf instance set 0 router-id=10.255.255.2
[[email protected]] /interface bridge add name=loopback
[[email protected]] /ip address add address=10.255.255.3/32 interface=loopback
[[email protected]] /routing ospf instance set 0 router-id=10.255.255.3

Konfigurasi OSPF area di MikroTik

Langkah berikutnya adalah untuk mengkonfigurasi OSPF Are. Backbone Area secara default sudah ada di MikroTik dan konfigurasi tambahan tidak diperlukan.  ID Backbone Area adalah 0.0.0.0 (selalu zero/nol).

Karena ada beberapa network menggunakan IP 10.10.1.0/30, 10.10.1.4/30, 10.10.1.8/30, di contoh ini saya hanya menggunakan network 10.10.1.0/24. Daripada setting satu-satu di setiap router.

Di R1 :

[[email protected]] /routing ospf network add network=192.168.1.1/24 area=backbone
[[email protected]] /routing ospf network add network=172.22.0.2/30 area=backbone
[[email protected]] /routing ospf network add network=10.10.1.0/24 area=backbone

Di R2 :

[[email protected]] /routing ospf network add network=192.168.2.1/24 area=backbone
[[email protected]] /routing ospf network add network=10.10.1.0/24 area=backbone

Di R3 :

[[email protected]] /routing ospf network add network=192.168.3.0/24 area=backbone
[[email protected]] /routing ospf network add network=10.10.1.0/24 area=backbone

Sekarang Anda pastikan Settingan OSPF di MikroTik Anda berfungsi dengan baik.

Cek tetangga OSPF Anda,  berstatus DR (Designated Router) dan BDR (Backup Designated Router, yang bertugas sebagai cadangan dari DR). Router yang memiliki Router ID tertinggi akan menjadi DR, kemudian disusul oleh Router ID terendah berikutnya yang akan menjadi BDR.

[[email protected]] /routing ospf neighbor print>

Pastikan ada route OSPF di masing-masing router (DAo)

[[email protected]] /ip route print
Sumber : http://www.modalsemangat.com/2015/06/contoh-cara-setting-ospf-di-mikrotik.html

Mengenal PPTP Tunneling Pada Mikrotik

Tunnel adalah sebuah metode encapsulation paket data di jaringan. Sering juga tunnel ini dikenal orang umum adalah sebuah jaringan VPN (virtual private network) dimana vpn ini difungsikan sebagai cara aman untuk mengakses local area network di lokasi lain dengan menggunakan akses internet atau jaringan public.

Jenis tunnel pada mikrotik ada banyak sekali yang bisa kita lihat pada list virtual interface. Salah satu penerapan tunnel sebelumnya telah saya bahas penerapan eoip tunnel sebagai bridging segmen layer 2. Kali ini saya ingin mencatat sebuah penerapan PPTP Tunneling pada mikrotik yang sedikit berbeda penerappanya dengan eoip tunnel.

PPTP adalah tunnel tipe client server, dimana PPTP server lebih banyak melalukan konfgurasi untuk setiap client yang ingin konek. PPTP membentuk tunnel PPP antar IP mengunakan protocol TCP dan GRE (Generic Routing Encapsulation). Kelebihan PPTP ini adalah secure, karena menggunakan enkripsi MPPE (Microsoft Point-to-Point Encryption), PPTP menggunakan port TCP 1723 dan  banyak digunakan karena hampir semua OS dapat menjalankan PPTP client.

Semua koneksi yang menggunakan protocol PPP selalu membutuhkan authentication username dan password, dimana authentication tersebut bisa diletakkan pada local router yaitu pada PPP Secret maupun di server luar menggunakan Radius. Pada PPP Secret, selain dipakai untuk authentication PPTP Client juga dapat dipakai untuk protocol ppp lainnya seperti : l2tp, openvpn, pppoe, dan sstp.

 

Biar gak penasaran langsung simulasikan PPPTP Tunneling ini menggunakan topologi seperti dibawah.

Untuk topologi diatas, saya analogikan router Mikrotik-1 sebagai pptp server sedangkan router Mikrotik-2 sebagai pptp client. Berikut keterangan alokasi IP address dari gambar diatas:

  • Mikrotik-1 interface:ether1 sebagai akses ke internet dengan ip public 12.12.12.1/24
  • Mikrotik-1 interface:ether2 sebagai akses ke jaringan local yang difungsikan sebagai gateway nya dengan ip address 10.10.1.1/24
  • Mikrotik-2 interface:ether1 sebagai akses ke internet dengan ip public 12.12.12.2/24
  • Mikrotik-2 interface:ether2 sebagai akses ke jaringan local yang difungsikan sebagai gateway nya dengan ip address 10.10.2.1/24
  • PC3 merupakan anggota dari jaringan local Mikrotik-1 menggunakan ip address 10.10.1.2/24 dengan gateway 10.10.1.1
  • PC4 merupakan anggota dari jaringan local Mikrotik-2 menggunakan ip address 10.10.2.2/24 dengan gateway 10.10.2.1

Berikut data ip yang telah dimasukkan.

[[email protected]] > ip address print 
Flags: X - disabled, I - invalid, D - dynamic 
 # ADDRESS NETWORK INTERFACE 
 0 10.10.1.1/24 10.10.1.0 ether2 
 1 12.12.12.1/24 12.12.12.0 ether1 

[[email protected]] > ip address print 
Flags: X - disabled, I - invalid, D - dynamic 
 # ADDRESS NETWORK INTERFACE 
 0 10.10.2.1/24 10.10.2.0 ether2 
 1 12.12.12.2/24 12.12.12.0 ether1

PC3> sh ip 
NAME : PC3[1]
IP/MASK : 10.10.1.2/24
GATEWAY : 10.10.1.1

PC4> sh ip
NAME : PC4[1]
IP/MASK : 10.10.2.2/24
GATEWAY : 10.10.2.1

Pertama, aktifkan pptp server pada Mikrotik-1 dengan perintah berikut

[[email protected]] > interface pptp-server server set enabled=yes

Kedua, karena untuk project kecil atau simulasi, disini authentication disimpan local saja yaitu di ppp secret. Buat satu user ppp dengan perintah berikut

[[email protected]] > ppp secret add name=user1 password=123 service=pptp local-address=192.168.10.1 remote-address=192.168.10.2

Dari perintah diatas, ppp secret untuk user1 hanya dapat dipakai untuk service pptp, kalau ingin digunakan pada service yang lainnya juga bisa diisi dengan service=any. local-address adalah ip tunnel yang akan di assign disisi pptp server sedangkanremote-address  adalah ip tunnel yang akan diberikan untuk pptp client.

Ketiga, aktifkan pptp client pada Mikrotik-2 dengan perintah berikut

[[email protected]] > interface pptp-client add name=pptp-out1 connect-to=12.12.12.1 user=user1 password=123

Perintah connect-to diatas diisi informasi ip public pptp servernya kemudian isi informasi user authenticationnya.

Keempat, cek status dial koneksi Mikrotik-2 sebagai pptp client,

[[email protected]] > interface pptp-client print 
Flags: X - disabled, R - running 
 0 R name="pptp-out1" max-mtu=1450 max-mru=1450 mrru=disabled 
 connect-to=12.12.12.1 user="user1" password="123" 
 profile=default-encryption keepalive-timeout=60 add-default-route=no 
 dial-on-demand=no allow=pap,chap,mschap1,mschap2 

[[email protected]] > interface pptp-client monitor numbers=0
 status: connected
 uptime: 20m20s
 encoding: MPPE128 stateless
 mtu: 1450
 mru: 1450
 local-address: 192.168.10.2
 remote-address: 192.168.10.1

Sekarang Mikrotik-2 sebagai pptp-client sudah terhubung dengan pptp-server dengan informasi status connected diatas.

Kelima, buat static routing dari router Mikrotik-1 ke network PC4 dan router Mikrotik-2 ke network PC3, karena pada step sebelumnya disetting add-default-router=no.

[[email protected]] > ip route add dst-address=10.10.2.0/24 gateway=192.168.10.2

[[email protected]] > ip route add dst-address=10.10.1.0/24 gateway=192.168.10.1

Keenam, lakukan validasi dari PC3 test ping dan traceroute ke PC4 dan juga sebaliknya

PC3> ping 10.10.2.2
84 bytes from 10.10.2.2 icmp_seq=1 ttl=62 time=25.003 ms
84 bytes from 10.10.2.2 icmp_seq=2 ttl=62 time=4.000 ms
84 bytes from 10.10.2.2 icmp_seq=3 ttl=62 time=4.000 ms
84 bytes from 10.10.2.2 icmp_seq=4 ttl=62 time=2.000 ms
84 bytes from 10.10.2.2 icmp_seq=5 ttl=62 time=4.001 ms

PC3> trace 10.10.2.2
trace to 10.10.2.2, 8 hops max, press Ctrl+C to stop
 1 10.10.1.1 7.000 ms 1.000 ms 1.001 ms
 2 192.168.10.2 9.001 ms 2.000 ms 3.000 ms *lewat ip tunnel/*
 3 *10.10.2.2 5.001 ms 

PC4> ping 10.10.1.2
84 bytes from 10.10.1.2 icmp_seq=1 ttl=62 time=4.000 ms
84 bytes from 10.10.1.2 icmp_seq=2 ttl=62 time=4.001 ms
84 bytes from 10.10.1.2 icmp_seq=3 ttl=62 time=4.000 ms
84 bytes from 10.10.1.2 icmp_seq=4 ttl=62 time=4.001 ms
84 bytes from 10.10.1.2 icmp_seq=5 ttl=62 time=5.000 ms

PC4> trace 10.10.1.2
trace to 10.10.1.2, 8 hops max, press Ctrl+C to stop
 1 10.10.2.1 1.000 ms 1.000 ms 1.000 ms
 2 192.168.10.1 4.000 ms 6.001 ms 2.000 ms
 3 *10.10.1.2 4.001 ms

Cukup enam langkah sudah sampai tujuan yaitu membangun jaringan client server menggunakan pptp.

Sumber :

Mengenal PPTP Tunneling Pada Mikrotik – http://wp.me/p7ugE3-18S

Upgrade Paket MikroTik

Upgrade adalah cara untuk menaikan level atau versi sebuah perangkat lunak dari level rendah ke level diatasnya. Upgrade juga dilakukan apabila anda ingin memperbaiki fitur apabila terjadi kesalahan (error). Dalam melakukan upgrade paket pada MikroTik.

Ada beberapa hal yang harus diperhatikan apabila ingin melakukan upgrading pada MikroTik.

  1. Harus memperhatikan level dan lisensi MikroTik yang berlaku,

  2. Harus memperhatikan arsitektur yang digunakan (arsitektur harus sesuai jenisnya) arsitektur MikroTik ada banyak diantaranya yaitu mipsbe dan smips dan penggunaan arsitektur ini tergantung dari perangkat routerboard yang kita gunakan.

Oke kita lanjut ke bagaimana langkah – langkah cara mengupgrade paket MikroTik.

  1. Download terlebih dahulu paket di http://www.mikrotik.com/download

LAB 5.1

  1. Perhatikan paket yang akan di download pilih sesuai dengan arsitektur yang dimiliki RouterBoard yang kita miliki.

LAB 5.2

  1. Download paket yang level versinya lebih tinggi dari paket sebelumnya. Misalnya di versi MikroTik anda versinya 6.30.2 maka download lah versi yang lebih tinggi dari 6.30.2 seperti 6.36.4

LAB 5.3

  1. Setelah di download file .rar / .zip tersebut di extrack , maka extansi dari paket – paket tersebut adalah *.npk

LAB 5.4

  1. Download paket yang akan digunakan untuk upgrading sudah selesai, sekarang saatnya anda untuk masuk ke MikroTik anda lalu pilih menu File, sambil anda buka file yang tadi sudah anda extrack. Caranya adalah dengan melakukan Drag and Drop dari file paket yang sudah di extrack kedalam menu File pada MikroTik. Lihat gambar dibawah

LAB 5.5

  1. Tunggu samapi proses upgrading selesai.

LAB 5.6

  1. Apabila proses upgrading sudah selesai, Reboot MikroTik sebagai Proses terakhir upgrading.

 

Melihat Lisensi Router MikroTik

Fitur – fitur RouterOS ditentukan oleh level lisensi yang melekat pada perangkat dan menentukan batasan upgrade packe. MikroTik memilik 6 nomor level lisensi mulai dari level 0, 1, 3, 4, 5 dan 6. Lisensi perangkat MikroTik disimpan di media penyimpanan, apabila media penyimpanan terformat maka lisensi tersebut akan hilang.

Berikut cara untuk melihat level lisensi pada perangkat RouterBoard

Akses Winbox –> Menu System –> License

LAB 3.1

LAB 3.2

Konfigurasi VPN dan PPTP pada Mikrotik

Virtual Private Network (VPN)

VPN dalah sebuah jaringan komputer dimana koneksi antar perangkatnya (node) memanfaatkan jaringan public sehingga yang diperlukan hanyalah koneksi internet di masing-masing site.
Ketika mengimplementasikan VPN, interkoneksi antar node akan memiliki jalur virtual khusus di atas jaringan public yang sifatnya independen. Metode ini biasanya digunakan untuk membuat komunikasi yang bersifat secure, seperti system ticketing online dengan database server terpusat.

Point to Point Tunnel Protocol (PPTP)

Salah satu service yang biasa digunakan untuk membangun sebuah jaringan VPN adalah Point to Point Tunnel Protocol (PPTP). Sebuah koneksi PPTP terdiri dari Server dan Client.
Mikrotik RouterOS bisa difungsikan baik sebagai server maupun client atau bahkan diaktifkan keduanya bersama dalam satu mesin yang sama. Feature ini sudah termasuk dalam package PPP sehingga anda perlu cek di menu system package apakah paket tersebut sudah ada di router atau belum. Fungsi PPTP Client juga sudah ada di hampir semua OS, sehingga kita bisa menggunakan Laptop/PC sebagai PPTP Client.

Biasanya PPTP ini digunakan untuk jaringan yang sudah melewati multihop router (Routed Network). Jika anda ingin menggunakan PPTP pastikan di Router anda tidak ada rule yang melakukan blocking terhadap protocol TCP 1723 dan IP Protocol 47/GRE karena service PPTP menggunakan protocol tersebut.

Topologi

Pada artikel ini akan dicontohkan apabila kita akan menghubungkan jaringan dengan menerapkan VPN dengan PPTP. Untuk topologi nya bisa dilihat pada gambar di bawah.

Router Office A dan Router Office B terhubung ke internet via ether 1 dan PC pada masing-masing jaringan lokal terhubung ke Ether 2. Remote client juga sudah terhubung ke internet.
Kita akan melakukan konfigurasi agar Router A dan jaringan LAN A bisa diakses dari Router B dan jaringan LAN B serta Remote Client. Langkah-langkah setting PPTP dengan Winbox sebagai berikut:

Konfigurasi PPTP Server
Berdasar topologi di atas, yang menjadi pusat dari link PPTP (konsentrator) adalah Router Office A , maka kita harus melakukan setting PPTP Server pada router tersebut.

Enable PPTP Server
Langkah pertama yang harus dilakukan adalah mengaktifkan PPTP server. Masuk pada menu PPP->Interface->PPTP Server . Gunakan profile “Default-encryption” agar jalur VPN terenkripsi.

Secret

Pada tahap ini, kita bisa menentukan username dan password untuk proses autentikasi Client yang akan terkoneksi ke PPTP server. Penggunaan huruf besar dan kecil akan berpengaruh.
Local Address adalah alamat IP yang akan terpasang pada router itu sendiri (Router A / PPTP Server) setelah link PPTP terbentuk
Remote Address adalah alamat IP yang akan diberikan ke Client setelah link PPTP terbentuk.

Contoh konfigurasi sebagai berikut. Arahkan agar menggunakan profile “Default-Encryption”

Sampai disini, konfigurasi Router A (PPTP Server) sudah selesai, sekarang kita lakukan konfigurasi di sisi client.

Client Router Office B
Langkah-langkah untuk melakukan konfigurasi Client PPTP pada Router Mikrotik adalah sebagai berikut :

Tambahkan interface baru PPTP Client, lakukan dial ke IP Public Router A (PPTP server) dan masukkan username dan password sesuai pengaturan secret PPTP Server.

Catatan : IP 10.10.10.100 adalah permisalan ip public dari server, Untuk implementasi sebenarnya sesuaikan dengan ip public yang Anda miliki.

Setelah koneksi PPTP terbentuk, akan muncul IP Address baru di kedua Router dengan flag “D” yang menempel di interface pptp sesuai dengan pengaturan Secret pada PPTP server

Static Route
Sampai disini koneksi VPN antar router sudah terbentuk, akan tetapi antar jaringan lokal belum bisa saling berkomunikasi. Agar antar jaringan local bisa saling berkomunikasi, kita perlu menambahkan routing static dengan konfigurasi

– dst-address : jaringan local Router lawan
– gateway : IP PPTP Tunnel pada kedua router.
Penambahan static route di Router A
Penambahan static route di router B

 

Mobile Client 
Client PPTP tidak harus menggunakan Router. Seperti pada topologi jaringan di atas, ada sebuah Remote Client (Laptop) yang akan melakukan koneksi VPN ke Router A.
Maka kita perlu membuat Secret baru pada PPTP server untuk autentikasi remote client tersebut.

Secret
username = client2 ; password = 1234 ; Local Address = 10.20.20.1 ; Remote Address = 10.20.20.7

Kemudian kita perlu melakukan konfigurasi PPTP Client pada Laptop. Langkah-langkahnya akan berbeda pada tiap OS. Berikut tutorial konfigurasi PPTP Client untuk OS Windows 7.

Konfigurasi PPTP Client Windows 7 
Pastikan Laptop anda sudah bisa akses internet. Masuk pada menu Network and Sharing Center, kemudian create koneksi baru dengan memilih Set up new connection or network.

Pada tampilan window selanjutnya, pilih Connect to a workplace , lalu klik next.

Kemudian, pilih Use My Internet Connection (VPN)

Pada langkah berikutnya, kita diminta untuk memasukkan ke IP Address mana kita akan melakukan koneksi. Sesuai topologi , maka kita masukkan IP address public Router A. Destination name adalah parameter untuk memberikan nama pada interface VPN yang sedang dibuat.

Selanjutnya masukkan username dan password sesuai pengaturan Secret yang ada di PPTP server. Lalu klik Connect.

Akan ada proses autentikasi, tunggu sampai selesai.

Jika sudah selesai, di laptop akan muncul interface baru dengan nama VPN Office A dan terpasang IP address yang mengambil dari ip-pool Remote Address sesuai dengan pengaturan profile dan Secret pada PPTP Server.

Sampai disini koneksi VPN dari Laptop ke Router A sudah terbentuk.  Laptop sudah bisa akses ke Router A dan Jaringan LAN A.

Untuk melakukan remote ke Router A tinggal anda masukkan IP addres Router yang terpasang setelah link VPN terbentuk, yaitu IP address 10.20.20.1.

 

Sumber : https://darmawangsa14.wordpress.com/2016/12/03/konfigurasi-vpn-dan-pptp-pada-mikrotik/

Mikrotik Standard Firewall rules + useful settings 

Firewall settings

/ip firewall filter

add action=accept chain=forward comment=”Accepted Connections” \

connection-state=established disabled=no

add action=accept chain=input comment=”” disabled=no dst-port=80 protocol=tcp

add action=accept chain=input comment=”” disabled=no dst-port=25 protocol=tcp

add action=drop chain=forward comment=”Drop invalid connections” \

connection-state=invalid disabled=no

Drop Virus Port

/ip firewall filter

add action=drop chain=forward comment=”Drop Virus Port” disabled=no \

dst-port=40016 protocol=udp

add action=drop chain=virus comment=”” disabled=no dst-port=135-139 protocol=\

udp

add action=drop chain=virus comment=”” disabled=no dst-port=135-139 protocol=\

tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1433-1434 \

protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=445 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=445 protocol=udp

add action=drop chain=virus comment=”” disabled=no dst-port=593 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1024-1030 \

protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1080 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1214 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1363 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1364 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1368 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1373 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=1377 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=2745 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=2283 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=2535 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=2745 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=3127 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=3410 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=4444 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=4444 protocol=udp

add action=drop chain=virus comment=”” disabled=no dst-port=5554 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=8866 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=9898 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=10080 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=12345 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=17300 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=27374 protocol=tcp

add action=drop chain=virus comment=”” disabled=no dst-port=65506 protocol=tcp

Drop Port Scanner

/ip firewall filter

add action=add-src-to-address-list address-list=PortScanner \

address-list-timeout=2w chain=input comment=”Drop Port Scanner” disabled=\

no protocol=tcp psd=21,3s,3,1

add action=add-src-to-address-list address-list=PortScanner \

address-list-timeout=2w chain=input comment=”” disabled=no protocol=tcp \

tcp-flags=fin,!syn,!rst,!psh,!ack,!urg

add action=add-src-to-address-list address-list=PortScanner \

address-list-timeout=2w chain=input comment=”” disabled=no protocol=tcp \

tcp-flags=fin,syn

add action=add-src-to-address-list address-list=PortScanner \

address-list-timeout=2w chain=input comment=”” disabled=no protocol=tcp \

tcp-flags=fin,syn,rst,psh,ack,urg

add action=add-src-to-address-list address-list=PortScanner \

address-list-timeout=2w chain=input comment=”” disabled=no protocol=tcp \

tcp-flags=syn,rst

add action=add-src-to-address-list address-list=PortScanner \

address-list-timeout=2w chain=input comment=”” disabled=no protocol=tcp \

tcp-flags=fin,psh,urg,!syn,!rst,!ack

add action=add-src-to-address-list address-list=PortScanner \

address-list-timeout=2w chain=input comment=”” disabled=no protocol=tcp \

tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg

add action=drop chain=input comment=”” disabled=no src-address-list=\

PortScanner

Drop Brute Force

/ip firewall filter

add action=accept chain=output comment=”Drop Brute Force” content=\

“530 Login incorrect” disabled=no dst-limit=1/1m,9,dst-address/1m \

protocol=tcp

add action=add-dst-to-address-list address-list=Blacklist \

address-list-timeout=23h chain=output comment=”” content=\

“530 Login incorrect” disabled=no protocol=tcp

add action=drop chain=input comment=”” disabled=no dst-port=22 protocol=tcp \

src-address-list=Blacklist

Drop Trace route

/ip firewall filter

add action=drop chain=forward comment=”Drop Traceroute” disabled=no \

icmp-options=11:0 protocol=icmp

add action=drop chain=forward comment=”” disabled=no icmp-options=3:3 \

protocol=icmp

add action=drop chain=input comment=”” disabled=no protocol=\

icmp src-address-list=!Local

Drop ICMP Ping

/ip firewall filter

add action=drop chain=input comment=”Drop ICMP Ping” disabled=no protocol=\

icmp

Drop Netcut Attack

/ip firewall filter

add action=accept chain=input comment=”NETCUT BLOCK” disabled=no dst-port=\

0-65535 protocol=tcp src-address=61.213.183.0/24

add action=accept chain=input comment=”” disabled=no dst-port=0-65535 \

protocol=tcp src-address=67.195.134.0/24

add action=accept chain=input comment=”” disabled=no dst-port=0-65535 \

protocol=tcp src-address=68.142.233.0/24

add action=accept chain=input comment=”” disabled=no dst-port=0-65535 \

protocol=tcp src-address=68.180.217.0/24

add action=accept chain=input comment=”” disabled=no dst-port=0-65535 \

protocol=tcp src-address=203.84.204.0/24

add action=accept chain=input comment=”” disabled=no dst-port=0-65535 \

protocol=tcp src-address=69.63.176.0/24

add action=accept chain=input comment=”” disabled=no dst-port=0-65535 \

protocol=tcp src-address=69.63.181.0/24

Block Mikrotik from discovery 

/tool mac-server

add disabled=yes interface=all

/tool mac-server ping

set enabled=no

/ip firewall filter

add action=drop chain=input comment=”block mikrotik discovery” disabled=no dst-port=5678 protocol=udp

add action=drop chain=input comment=”ALL WINBOX REQUEST By MAC Address” disabled=no dst-port=20561 protocol=udp

add action=drop chain=input comment=”ALL WINBOX REQUEST EXCEPT FROM MY PC” disabled=no dst-port=8291 protocol=tcp src-address=!192.168.2.6

Allow VPN (PPTP) Connections for Mikrotik VPN Server

\ip firewall filter

add action=accept chain=input disabled=no dst-port=1723 protocol=tcp

add action=accept chain=input disabled=no protocol=gre

 Sumber : Mikrotik Standard Firewall rules + useful settings – http://wp.me/p8hKmO-Z

Add Ip Address dan IP Gateway

Internet protocol Address atau biasa disebut IP Address dapat dipasang di beberapa perangkat jaringan, seperti wireless, Lan card, dan bridge. Khususnya dimikrotik, kita bisa menambahkan IP di interface yang sudah dijelaskan sebelumnya. IP ini berfungsi sebagai alamat untuk pengiriman dan juga penerimaan data antar perangkat.

Caranya tinggal ketik command :

[[email protected]] > Ip address add address=[ip_baru] interface=[interface_yang_dituju]

Pengecekan :

[[email protected]] > Ip address print

o1

Sedangkan IP Gateway adalah ip yang berfungsi untuk menghubungkan jaringan local atau LAN dengan jaringan publik atau internet atau bisa sebaliknya. IP Gateway diibaratkan sebagai pintu keluar/masuk atau sebagai sebuah gerbang antara LAN dengan Internet. Misalnya nih, kita punya jaringan local dengan ip address 192.168.0.0/24, nah kita mau menghubungkan jaringan tersebut dengan internet dengan memakai modem yang memiliki IP 192.168.1.1/24. Nah nya lagi, IP modem tersebut sebagai gateway atau penghubung tadi, dengan tujuan routing yaitu ip internet.

Cara konfigurasinya, kita hanya tinggal mengetik command :

[[email protected]] > ip route add=[ip_gateway]

o2.png

http://wp.me/p8AU7C-mE

%d bloggers like this: